pggw.net
当前位置:首页 >> ApAChE liBphp5.so >>

ApAChE liBphp5.so

libphp5.so是php5提供的,你还需要编译php5才能生成这个文件 你在PHP的configure的时候,加上: --with-apxs2=/usr/local/apache/bin/apxs 这样就会自动编译一个libphp5.so出来了。

安装目录 和 最后程序安装位置没有关系 你删掉的可能是解压后的目录 通过 find / -name 'php.ini' 来寻找安装目录 不过不建议这样操作

每个版本的PHP编译出来的libphp5.so是不一样的,你这样估计不能解决问题。 你在PHP的configure的时候,加上: --with-apxs2=/usr/local/apache/bin/apxs 这样就会自动编译一个libphp5.so出来了。 注意:/usr/local/apache/bin/apxs 路径要改成你...

libphp5.so是php5提供的,你还需要编译php5才能生成这个文件 你在PHP的configure的时候,加上: --with-apxs2=/usr/local/apache/bin/apxs 这样就会自动编译一个libphp5.so出来了。

安装的时候需要制定 apxs 路径 具体参数是--with-apxs2= apxs 是apache提供的模块安装工具,php作为apache的一个模块加载进来,就必须指定他的路径。 希望能够帮助到你,有问题可以随时私信交流。

libmysqlclient.so.16: cannot open shared object file: No such file or directory 人家说的是没有找到 libmysqlclient.so.16 。 也就是你的 php 安装有问题,导致依赖不满足,apache 无法调用 libphp5.so 这个 libmysqlclient.so.16 应该在 m...

/usr/local/httpd/modules 还是 /usr/local/httd/modules ? 差个'p'呢

libphp5.so是php5提供的,你还需要编译php5才能生成这个文件 你在PHP的configure的时候,加上: --with-apxs2=/usr/local/apache/bin/apxs 这样就会自动编译一个libphp5.so出来了。

由于好久没有搭环境,在Linux上搭apache、PHP的环境时,遇到libphp5.so 无法生成这个问题,我也困扰了我半天,很是郁闷。从网上找了各种资料,都是瞎转载,太无聊的一堆人了,自己成功没有成功的先转载,鄙视。 害的我尝试了半天也没有解决。下...

细细的看了一下楼主和各位的讨论。 楼主说了对httpd.conf的改动情况,但是最关键的116行却没有给出, /usr/local/apache/conf/httpd.conf 另外还有一点儿,我感觉错误信息的意思是libmcrypt.so.4 加载不到libphp5.so,希望楼主照此思路再检查一下。

网站首页 | 网站地图
All rights reserved Powered by www.pggw.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com